Microsoft Edge Not Displaying Site

After I registered as you suggested in your prior email, Microsoft Edge in Windows 10 will not display the User Group website from either the link directly ( or from the dropdown to the User Group from Firefox displays with no issues.

Tom Owen
Dahlgren Yacht Club

I’m on Windows 10 with Edge and got straight on from your direct link

Hi Tom,
I’ve tested it on Windows 10 using Microsoft Edge and it works fine for me.
And I see Ralph has also tried it with Edge and it worked for him as well

Do you have any more information on why it doesn’t display the site are there any error messages displayed?


When I try to access results using Edge or IE11 I get a message that says:

Your connection isn’t private

Attackers might be trying to steal your information from xxxxxxxx (for example, passwords, messages or credit cards).


xxxxxxxx uses encryption to protect your information. When Microsoft Edge tried to connect to xxxxxxxx this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be xxxxxxxx, or a WiFi sign-in screen has interrupted the connection. Your information is still secure because Microsoft Edge stopped the connection before any data was exchanged.

You can’t visit xxxxxxxx right now because the website sent scrambled credentials that Microsoft Edge can’t process. Network errors and attacks are usually temporary, so this page will probably work later.

Something needs to be fixed …

Hi Mike,

No problem here. What address are entering into the address bar?

Using Edge I get

Using Chrome


Hi Mike,
No problem using latest version of Edge to access Sailwave website. I used the non secure address of and was automatically changed to the secure address of

Kind regards,

Resend with fewer screenshots, since I am allowed only one.

Hi Mike,
What address did you enter in the address bar,
Is this a consistent message you get or an intermittent message?
Certainly, no problem here using Edge it works fine as per my earlier email.

As it’s been a while now since you first mentioned this and no others have mentioned any problems - Others here have confirmed it is all working fine for them it would appear to be something with your setup. I’m happy to investigate if you can give me more information.

Is it OK with Chrome and Firefox?
Is it OK on your phone using Edge. Tried it on my phone using Edge and no issues



The address was: (a link from the SYC website).

This always happens with Edge.

With IE11 I get this warning:
"This site is not secure
This might mean that someone’s trying to fool you or steal any info you send to the server. You should close this site immediately
The hostname in the website’s security certificate differs from the website you are trying to visit.

I can go past it and get in by selecting “Go on to the webpage (not recommended)” beneath the above warning.

Chrome seems to be OK; don’t have Firefox. Safari on my iPhone lets me in OK too.

Regards, Mike

Hi Mike,
My Microsoft Edge is up to date.
Version 85.0.564.51 (Official build) (64-bit)

I do get a warning “Not secure” in the address bar which when I click shows this in the pop-up window

which basically says “Your connection to this site isn’t fully secure.” It is complaining that the Facebook & Twitter images might be able to be modified by malicious attackers.

Which version of Microsoft Edge are you using as you mention IE11 in your last post?

Look forward to getting your problem resolved.
Kind regards,

Hi Mike,
The issue is that the certificate is for and not if you publish
the www in the link e.g.

then you won’t see this issue - so that is a solution

Having said that - I don’t understand why you see this with Edge
As I said the certificate is for but the IIS serving the website has rules that redirect the browser to use if it finds just and this works on my PC for both Edge and Chrome
If you type into the address bar using edge on My PC then it redirects to and although I typed you see it changes to This also works for Chrome
I did just manage to reproduce your issue using safari on an iPad - Why this redirect doesn’t work on the iPad I don’t know.

Why it should work on my PC (and others) using Edge but not yours I don’t know. But the solution is to add the www. to the link and there are no issues

On another topic, the use of the socialshare effect is causing a not secure to appear in the taskbar. Although this is not a major issue it can easily be fixed. The socialshare.js which can be found at C:\Users\Public\Documents\Sailwave\Javascript\socialshare.js needs to be updated to use the https address of the Facebook and Twitter images.
The updated version V1.1 of socialshare can be found in the effect library on the Sailwave website (Use right click and select download as)

Let me know if you have any questions