RRS plugin issues in 2.33.0

Installed 2.33.0 and used (parallel to 2.30.3 which was a production machine) on the last event. Almost all was working as expected, except two (but either not blocking) issues:

  1. When I exported the competitor data from Sailwave to RacingRulesOfSailing Event using the plugin, only few competitors received the Nationality attribute into RRS. All other were empty (blank?).
    I used the SailNo column with the NAT inside (like XYZ 123456) and a separate Nationality Column with the Nat code (XYZ), so at the end no problems for the RRS Competitors list.

The similarity I found, but not proved yet to be a rule, is that only Nationality codes which were unique in Sailwave (only one competitor from this state) were transferred to RRS Nationality column.

  1. I am using Sailwave under Wine (PlayOnLinux on Mint 21.3). When using the export to RRS plugin, I received a strange message window about “not finding Sailwave working” (I cannot reproduce it now), but the data was transferred (see Note 1). In a Windows Virtual Machine (KVM) there was no such error message with same result in RRS.

Hi Walter

It would be very strange if some of the Nat fields transferred but not others but I’m happy to have a look If you would like to share the Sailwave file .blw with me (jon@sailwave.com)

Re topic 2 Thanks I’m aware of that message coming up occasionally but it is mostly when running on non windows systems or running under virtual machines. I have a simple fix for it but it’s not worth issuing a new version just for that as it is still fully working.

Jon

1 Like

Hi Jon,

I sent you the blw, and the link to the test RRS event (you have Editor rights) to see the results.

For the topic 2, I am OK with that, since the message is informational, no consequences on the export process.

Walter

UPDATE

The issue was at RacingRules of Sailing - This has now been fixed. It occurred because of some change RRS made

Note that now RRS don’t use the same country code as World Sailing
e.g. Switzerland is SUI for World Sailing but RRS are using CHE and are converting them which I personally think is rather confusing but that is a matter for RRS and its users
Croatia is CRO for World Sailing but HRV for RRS

Jon

1 Like

I am testing the new plugin. After pressing Update, Status shows Processing Competitors, then Connected to Server, immediately followed by an error box: Invalid command specified.
Any ideas?
Evert

Hi
Thank you for reporting this issue. We have had it reported by one other user and on investigation the Invalid command is coming from the Irish Sailing Server. I have submitted the error to them and I’m currently awaiting their response. It may be something is wrong with the data being submitted but I’ve looked at it and it appears to be fine. So I need to know what command they are rejecting and why.
Once I’ve have an answer I’ll let you know

Many thanks

Jon

Hi Evert

I have found the issue that was causing the Invalid command in the other persons case. This was due to some special characters that they had used in the Event name Hex characters 91 and 92 in this case

Is your problem similar have you used any non standard ASCII characters in the event name or maybe elsewhere?

If you still have a problem please send me the .blw and I’ll investigate it for you (jon@sailwave.com)

Regards

Jon

Hi Jon,

I am usually using UTF8 character set in CSV to import competitors, getting some “garbage” dual byte symbols in Sailwave screens for croatian symbols, but exporting or publishing results to RRS or browsers i get them again OK.

So, using UTF8 no export problem.

I can check with croatian symbols entered in application (single byte Eastern Europe ASCII variant) later.

Walter

Hello Jon,
My column names are bilingual with
separating the 2 languages so they are forced to display on 2 lines. I suppose that’s where the problem lies.
I assumed that the default/original column names would be used for the transfer.
Evert

Hello Jon,
Paul Z pointed out to me the presence of an apostrophe in the Event Name. All is good now even with instances of
in the event and/or column names.
Evert

All is good now even with instances of “
” in the event and/or column names.

Hi Evert - Thanks for the update. I did find a similar issue with one use using the Irish Sailing Plugin. Where they were using one of the unusual apostrophes. The easy thing was to remove it and all was good but I did find that if I converted the text to UTF-8 then that cured it also so for a future edition of the plugin I will also add that to the RRS plugin

Jon

I tried to export a competitor list to RRS where all user (with some names using Croatian characters šđčćž ŠĐČĆŽ) were imported from UTF-8 CSV. The export was good. After that, just one competitor was added at last moment through “New competitor” Sailwave function, with the “ž” in Surname (single byte).

Trying to export again the data to RRS, I got “Invalid command entered”.

Changed this competitor using “Edit cells” from “ž” to “z” (single byte ASCII), all transfered OK.
Changed to UTF-8 dual byte code Croatian symbol, all transferred OK.

So the cause of the problems in my case are the single byte Croatian symbols (>7Fh), at least some of them.

I think the good solution would be (if possible) to switch the entire application to UTF-8, dropping the single byte national solutions used today. It will solve also the dual byte garbage displayed in Sailwave for nation specific symbols when imported from the UTF-8 CSV text file (p.e. LibreOffice Calc).

Since I am publishing Sailwave results to browser and print them to PDF, all characters (in UTF-8) are at the end published as expected. The issues in publishing also (not only in exporting to RRS) are manually changed competitor name fields, column names or Event name fields containing single byte croatian symbols entered through Sailwave, they are wrongly displayed as strange “question mark rectangle” in UTF-8 html or PDF.

Walter

Hi Walter,

https://www.dropbox.com/scl/fi/mzger9w15pcgb1w03ihaz/Swrrs.EXE?rlkey=7a5r142dzu6gtkyxa61h0hez2&dl=0
This is Version 1.0.4 please download and replace the version in your Sailwave directory

This one has conversion to UTF-8 encoding for the Event Name and also the Helmname as it sends it to RRS.

I’m interested to see how it gets on with your characters

Look forward to hearing from you

Jon

Done the test:

Premise on the test: Competitors are imported from UTF-8 CSV file. Just one is later directly added into Sailwave (name with ž), as described in previous post.

The single byte ASCII Character “ž” entered through Sailwave now is transferred well to RRS. But all other UTF-8 already existing characters in other competitor names are now transferred as double characters: one example: ć instead of ć. (behavior not seen before)

These double byte strange characters are the same I can usually see in the Sailwave screens when I import a UTF-8 competitor file, the good is that all is later well printed as results to PDF through browser.

The latest version is now included in Sailwave 2.33.2 Full install

Jon

Hi Walter
I would like to see the files you are using to see what I can do for you if possible
(jon@sailwave.com) I always import as ANSI and usually have little problems if I do that.
If the CSV is not ANSI I use the Notepad++ (which is free) to convert it from UTF-8 to ANSI
image
Perhaps it would be a good idea to do this automatically when importing
I’ll try and experiment soon
Jon

I will sent you, as I reach the computer.
I am using UTF-8 in CSV import and in browser for result publishing for years, not ANSI, since it minimizes problems with Croatian symbols.

I will try to explain.

System Linux Mint 21.3, PlayonLinux, Sailwave, Locale-charmap UTF-8.
Sailwave “Language” Eastern Europe
Whatever input I use (WIn1250, ISO-8859-2, UTF-8 for the import, I can’t get Croatian symbols in Sailwave, the only way to have them on reports is importing UTF-8 from CSV, use them as displayed in Sailwave, Publish to browser. If I use other ASCII encodings (Win1250, ISO8859-2), no Croatian symbols in browser. Some time ago, there was a setting in Firefox to change the character set back to one used, I can’t find it now (and it is not necessary in UTF-8)