Unusual behavior in version 2.29


I was scoring a series last weekend using Sailwave 2.29.0 and I experienced some unusual behavior.

I had a short series of two races and each race was a timed race. When I went to enter the finish times using Sail Num Wizard for every boat I went to enter it defaulted to ‘Place or retirement code’. I then had to select the third option ‘Start time and finish time or retirement code’ and I had to manually put in the start time. I checked and the races were definitely set to be timed races. I closed the series and reopened it and it worked fine.

Another problem is I had one fleet set to progressive handicaps (NHC / External / Excel link to swecho.xls). When I scored the series there was no ‘New Rating’ calculated. This was unusual as this always works. I wasn’t sure how to resolve it so I closed the series, shut down Sailwave, opened it up again and then when I scored it again it worked.

Trying to recreate either of these would be very difficult. The one thing that seems to address both issues was closing the series and Sailwave and then reopening.

One thing that might have caused the first problem is a few weeks ago I was showing some people Sailwave and to show how to enter a one design fleet I changed one race to be a ‘Place’ scored race and then after showing them I changed it back to be a ‘Timed’ race. I wonder in doing this was some internal setting set that remained set last weekend?