Windows 11 Pro Defender Preventing Installation

I am at a loss and wanted to see if you have any suggestions.

My prior system was a Dell Inspiron 16 Plus – 7620 running Microsoft Windows 11 Home Version 10.0.22621 Build 22621 that had been updated regularly. I used Avast Anti-Virus with no real issues.

I had to replace my computer due to hardware failures November 11, 2023 with a Dell Latitude 5280 running Windows 2011 Pro Version 10.0.22000 Build 22000. This system is not on the approved list for update to 22H2, but I do not know the specific issue why it is non-compliant. It only says the CPU (Intel(R) Core™ i7-7820HQ CPU @ 2.90GHz, 2901 Mhz, 4 Core(s), 8 Logical is not supported even though it is conditionally on the list of supported CPUs.

Based on the recommendation from the seller, I did not install Avast on the new system, but used Defender instead. I was able to install 3rd party software (e.g. Libre Office, Quicken, Sailwave, Netbeans, apps I developed in Java, etc.) but due to Defender’s security rules, the apps were denied write access to my (user) folders. So when I received the notification that the app was denied write access, the workaround was to navigate to Virus and threat protection → Ransomware protection: Manage ransomware protection → Controlled folder access: Allow an app through Controlled folder access → Add an allowed app → Recently blocked app and then select /allow the offending app. This has worked for multiple installed apps including Sailwave.

When I tried to install the latest full install of Sailwave (sw2_33_2.exe), Defender blocked the install, so I tried to do the workaround. The offending app in the list of blocked apps was a C:\Users\owner\AppData\Local\Temp\G.tmp*, but that is not the installing app, but a tmp file that was part of the installation. The install failed and closed. When I went to C:\Users\owner\AppData\Local\Temp to find the offending file, it was gone which I assumed was part of the install cleanup process.

I then tried to install (sw2_30_2.exe) with the same results other than a different tmp filename.

I then installed Avast, and the next installation attempt worked fine. There must be other Sailwave users that just rely on Defender as their anti-virus. Any suggestions would be most appreciated.

Tom Owen

I had the same Sailwave installing issue with Norton 360. I forced it to accept the program and all is well now.



Did you try disabling Defender (temporarily) while doing the SW install?

No I did not. Thanks for the suggestion.