World Sailing Interface - Failed Fetch

When I try to find my event on the World Sailing Event Finder screen of the Sailwave WS Interface I get a “Failed fetch from World Sailing” notice in the bottom left corner of the popup box. I’ve upgraded to the latest version of Sailwave, searched the forums, watched the video, read the manual, turned off my windows firewall, run as administrator, rebooted the pc and still get the same error. Any ideas? I’m using Sailwave 2.30.2 on Windows 11 Home.

Thanks in advance,


Hi Eileen,
Firstly welcome to the Sailwave User Group forum.

We are aware that the SS event look up is not working and neither is the upload of results to WS. The parts of the WS plug-in that work are the SailorID lookup and the creation of a file to of results to send by email to WS.

WS broke most of the interface between Sailwave and WS server when WS upgraded their website over 18 months ago. Sailwave are waiting for details of how to connect Event Finder tab to WS event lookup and to the results upload interface.

Because of your post reminding me of this issue, I will chase WS againabout providing information need to get all parts of the Sailwave WS plug-in working.

I am sorry I cannot be more helpful at the present time.
Kind regards,

Thanks. I’m glad to know it’s not something I did.

I hope you get farther with WS this time around.


For the last 4 ILCA Worlds championships I just save the data to a file and emailed the file to Matt at Worlds sailing. It worked out fine and in this way you don’t have to deal with the incorrect WS id’s that sailors entered.