White Text on White background in pop-up editing windows

Hi SUG Users on Linux,

I have encountered a problem since my system upgraded to WINE 7.6.

My system information:

I am using Sailwave is v2-29-6

When I, for example, try to edit competitor information, the edit competitor window opens but all text is white on a white background. Which makes things a bit difficult to say the least!
2022-04-23_11-06

Any window popped up by Sailwave to edit information is the same.

Any other Linux users of Sailwave experienced this problem and found a solution?

The issue is also present on my openSUSE Tumbleweed system running the Mate desktop.

I will be checking by on my Ubuntu (20.04 LTS) and openSUSE Leap 15.3 systems to see what version of WINE they are using and if the same problem exists. But this seems to have started since I started using WINE 7.6.

I look forward to any feedback.
Kind r egards,
Huw

Hi Huw,
I’m using Mint, and just tried adding the Wine PPA and installing version 7 to test. I still can’t seem to get my system to start with any version of WINE higher than 5.5.

Perhaps try purging the version of WINE you have and installing a prior version?

Finally got version 7.00 to install on Mint 20. No versions above that. Seems to work okay.

Hi Andy,
Thank you for your information.

It is the change from WINE 7.5 to 7.6 and/or associated wine-mono & wine-gecko in openSUSE Tumbleweed the rolling distro that has changed things.

  • Ubuntu 20.04 LTS with WINE 7.0 -Sailwave OK
  • Linux Mint 20.3 with WINE 5.0 stock Mint version - Sailwave OK
  • openSUSE Leap 15.3 with WINE 6.0 stock Leap version - Sailwave OK
  • openSUSE Tumbleweed with WINE 7.6 latest version - Sailwave not OK
  • openSUSE Tumbleweed with WINE 7.5 - Sailwave OK from memory but to be retested when I work out how to install previous version.

Will test Ubuntu 22.04 LTS and stock WINE install tomorrow.

Thanks again Andy for your information.
Kind regards,
Huw

OK

Hi everyone,

A small update after installing Ubuntu 22.04 LTS

Wine 6.0 installed from Ubuntu repository - Sailwave OK

WINE 6.0 from Ubuntu repository uninstalled.

WineHQ repositories installed and winehq-devel installed which is v7.7 - Sailwave not OK

Kind regards,
Huw

Hi everyone,

A quick update.

I have found a solution to no text appearing in for example Edit Competitor pop-up window :slight_smile: when using openSUSE Tumbleweed system running WINE 7.7. Still to be tested on other Linux environments.

Open ‘Configure Wine’ , found by entering Wine in the menu search box. When the Wine configuration window opens select ‘Desktop integration’ tab, now select from drop down list beside Theme box ‘(No Theme)’ followed by clicking Apply button.
2022-04-29_11-41

Now re-open Sailwave double click a competitor to open Edit Competitor window and one should no see the text! :slight_smile:

One issue solved, now on to the next.
Kind regards,
Huw